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About the Book
At a Glance

Document Scope This manual contains a quick start for Unity SFC View.

Validity Note This manual applies to Unity SFC View 2.0 with Unity Pro 2.0, OPC Factory Server 
3.1, Microsoft Windows 2000 or Microsoft Windows XP Professional.

Related 
Documents

Title of Documentation Reference Number

Unity SFC View User Guide -

Unity Pro Reference Manual -

OPC Factory Server User Guide TLX DM OFS x.x

Vijeo Look  SCADA software for small and medium monitoring 
applications

-
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About the Book
Product Related 
Warnings

The data and illustrations found in this document are not binding. We reserve the 
right to modify our products in line with our policy of continuous product 
development. The information in this document is subject to change without notice 
and should not be construed as a warranty by Schneider Electric.
Schneider Electric assumes no responsibility for any errors that may appear in this 
document. If you have any suggestions for improvements or amendments or have 
found errors in this publication, please notify us. 
No part of this document may be reproduced in any form or by any means, electronic 
or mechanical, including photocopying, without express written permission of 
Schneider Electric. 
All pertinent state, regional, and local safety regulations must be observed when 
installing and using this product. For reasons of safety and to ensure compliance 
with documented system data, only the manufacturer should perform repairs to 
components. 
When controllers are used for applications with technical safety requirements, 
please follow the relevant instructions. 
Failure to use Schneider Electric software or approved software with our hardware 
products may result in injury, harm, or improper operating results. 
Failure to observe this product related warning can result in injury or equipment 
damage.

User Comments We welcome your comments about this document. You can reach us by e-mail at 
TECHCOMM@modicon.com
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General information
Introduction

Overview This chapter contains general information about quick start for Unity SFC View.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

General 8

System requirements 9

Installation and Registration 10

Unity Pro presettings 10
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General information
General

Goal of the 
documentation

The documentation is intended to help you integrate SFC View as quickly as 
possible and in a targeted manner into a HMI application.
You can then display step chains of a Unity Pro test project that is contained in the 
delivery scope of SFC View, in the three following views of SFC View:
� Overview
� Details
� Details Simple.
In addition, you can send the following commands to the PLC for a step chain:
� Next step
� Set Initialize Flag
� Reset InitializeFlag

Programming 
environment

Programming environment in this case is Vijeo Look 2.5.
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General information
System requirements

Operating 
System

One of the following operating systems is required:
� Microsoft Windows 2000
� Microsoft Windows XP Professional

Unity Pro 
Version

Unity Pro V2.0 must be installed at least once on the system.
 

SFC View Library The SFC View library must be installed (update type library).
 

OPC Factory 
Server

An OPC Factory Server (OFS) Version 3.1 must be installed on the system.
 

ActiveX 
Container

The programming environment is a HMI application that supports ActiveX container.

HMI Application HMI applications tested for Unity SFC View are:
� Monitor Pro 7.2, Schneider Electric
� Vijeo Look 2.5, Schneider Electric
� iFix 3.0, GE Fanuc
� InTouch 7.2, Woderware
Other applications tested are:
� Internet Explorer 6.0, Microsoft
� Visual Basic 6.0, Microsoft

PLCs supported The following PLCs programmed with Unity Pro are supported:
� Quantum
� Premium
� Atrium
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General information
Installation and Registration

Installation 
Sequence

Observe the installation sequence specified in Unity SFC View User Guide.

Installation Install the required software (Unity Pro, OPC Factory Server, SFC View, HMI-
Software) as described in the associated manuals. 

Registration Register the required software as described in their respective manuals. 

Unity Pro presettings

General Before the SFC View can be used, Unity Pro must be configured in a certain way.

Diagnostics Make sure that under Tools → Project settings... → Build → Diagnostics the 
option Application diagnostics is selected and the application level is set to Local 
Diagnostics.

Sequential 
Function Chart 
(SFC)

Make sure that under Tools → Project settings... → Language extension the 
Allow multiple token option is not selected.

Save project 
automatically

Make sure that under Tools → Options → General → Save project automatically  
the option On Download is selected.

Note: These settings must be configured separately for every Unity Pro project.

Note: This setting is required if the SFC View diagnosis is carried out via the PLC 
diagnosis buffer.
10    
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Testing SFC View using the 
demo application
Introduction

Overview This chapter contains information on the possibility of testing and learning 
SFC View using the demo application.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

General 12

Start and Use of the SFC View Demo Application 12
11



Testing SFC View using the demo application
General

Prior to the 
Integration of 
SFC View

Before you integrate SFC View into an HMI application, you should test for flawless 
interplay between SFC View, Unity Pro, the OPC Factory Server (OFS) the Unity 
Pro PLC Simulator.

SFC View Demo-
Application

In order to test SFC View and to perform a few important adjustments, please use 
the SFC View Demo Application as described in the following.

Start and Use of the SFC View Demo Application

General When installing SFC View, a SFC View Demo Application and the corresponding 
source code (in Visual Basic) are installed.
The SFC View Demo Application is an independent program that can also be 
executed without HMI, SPS and Visual Basic.
Nearly all the properties, methods and events for SFC View were configured in this 
program, are available using menus and can be tested in conjunction with Unity Pro, 
the OPC Factory Server (OFS) the Unity Pro PLC Simulator.
The user can experiment with this demo application and learn how SFC View is used 
and programmed.

Source code If the user's development environment is Visual Basic 6.0, the source code for the 
demo application can be viewed in it.
If a different development environment is used, the Visual Basic source code can be 
viewed in any editor.
The Visual Basic files can be found in the default directory: ...Installation 
directory of the SFC View...\SFC View\Example.

Saving the Unity 
Pro test project

The Unity Pro test project that belongs to the demo application is saved during the 
installation of SFC View as an *.XEF-file as a standard under ...Installation 
directory SFC View...\TESTSFC.

Settings for the 
conversion 

Note: Before the Unity Pro test project can be converted, the SFC View library 
must be installed.
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Testing SFC View using the demo application
Converting the 
Unity Pro Test 
project

The following table describes the procedure for converting the Unity Pro test project.

Settings The demo application only works properly if all the presettings were made correctly 
(Unity Pro presettings, p. 10).

Loading the 
Unity Pro test 
project in the 
PLC simulator

The following table describes the procedure for loading the Unity Pro test project into 
the PLC simulator.

OFS 
configuration 
tool

Before the SFC View can be used, the OFS configuration tool must be configured in 
a certain way.
Execute the command  Start → Program → Schneider Electric → OFS → OFS 
configuration tool. 

Options In the tab Options under Features the following option must be selected:
� Enable OPC Extensions

Step Action

1 Launch Unity Pro.

2 Open the TESTSFCV.XEF file via File → Open.

3 Generate the project via Build → Rebuild All Project.

4 Save the project via File → Save using the name TESTSFCV.STU.

Step Action

1 Launch Unity Pro.

2 Open the TESTSFCV.STU file via File → Open.

3 Via PLC → Connect... create a connection to the PLC simulator controller.

4 Via PLC → Transfer Project to PLC load the program into the PLC simulator 
controller.
Note: If you select the PLC RUN after transfer option, the PLC starts 
automatically after the program is transferred.

Note: In case the tab Options is not displayed, via the command button 
Advanced... all tabs can be shown.
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Testing SFC View using the demo application
Comm. settings In the Comm. tab in Options for devices without alias the following option must 
be selected:
� Check Consistency

Create Alias for 
demo application

An alias is required to ensure that SFC View and OFS can work together. The 
following table describes the procedure to create an alias for the demo application.

Note: If the Comm. tab is not shown, all of the tabs can be shown via the 
Advanced... tab.

Step Action

1 Click the Alias tab.

2
Click the  (Create new alias) button.

3 Enter as the ame TESTSFCV .

4 Click on the <Driver> field:<PLC addr> and using the Arrow down open the 
page to enter the driver name.

5 In the ADDRESS tree structure on the left click on DIRECT → TCP IP.

6 For the TCP IP address enter 127.0.0.1 and for the PLC select UNITY.

7 Confirm your entries using OK.

8 Click in the Symbol table file and using the arrow pointing down select the 
page to select the symbol file.

9 For the file type select File type UnityPro project file (*.stu) and for 
the file select File TESTSFCV.STU.

10 Confirm your selection using Open.

11 Click on the button  Alias properties... and check the Check Consistency 
option. Confirm the option is activated using Validate.

12 Now confirm all of your entries for the Alias TESTSFCV using Apply.
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Testing SFC View using the demo application
Test the 
connection 
between the OFS 
and the PLC

The following table describes the procedure for testing the connection between the 
OFS and the PLC.

Diagnosis 
window for the 
OFS

Errors which might appear are shown in red in the OPC Factory Server diagnosis 
window.

Diagnosis 
window not 
visible

The installation of a HMI application (e.g. Vijeo Look) can make it so that the 
diagnosis window of the OPC Factory Server is not visible in the foreground and is 
displayed only as an icon in the footer line of the screen.
If this is the case, run the program ChangeOFSSettings.exe . This program is 
saved during the installation of SFCView as a standard under ...Installation 
directory of the SFCView...\ .
So that the change is effective, you must restart, via Start → Programs → 
Schneider Electric → OFS , the OPC Factory Server .

Step Action

1 Start the OFS client via Start → Programs → Schneider Electric → OFS → 
OFS Test Client.
Note: The program OFS Client is only available if the appropriate option was 
selected for the OFS installation.

2 Click on Schneider Aut.OFS as server and confirm using OK.

3 Create a new group via Group → New Group... and give it the name: e.g. 
GRP1.

4 Under Notification activate all the options and select the following settings:
� Update rate: 1000 ms
� Dead banding: 0.000000 [0.0,1.0]
� OPC version: Auto
Confirm with OK.

5 Via Item → New... open the AddItem window.

6 In the tree structure in the left window of the project select TestSFCV. The 
project variables are shown in the right hand window.

7 Click on the variable e.g. ACT1 and confirm with OK.

8 If a green symbol appears to the left of the variable in the properties window 
which now appears, the connection between the OFS and the PLC is intact.
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Testing SFC View using the demo application
Starting the 
demo application

The following table describes the procedure for starting the demo application.

Using the demo 
application

Use the items View and Run in the main menu to activate and deactivate the 
individual properties, methods and events in SFC View and to observe the changes 
to the individual views.

Step Action

1 Execute the command  Start → Program → Schneider Electric → Unity SFC 
View → SFC View Demo Application.

2
Select, via the command button  the Project TestSFCV to be opened and 

confirm using OK.

3 The project data are loaded from the Unity Pro project.

4
Start the demo application via the  demo application button .

5 Select the appropriate view via one of the following command buttons:

�  Overview

�  Details

�  DetailsSimple
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Integration of SFC View in 
Vijeo Look
Introduction

Overview This chapter contains information on the integration of SFC View in Vijeo Look.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Nature of Tasks 18

Configure new project and Prepare SFC View-ActiveX 19

Create New Overviews 20

Shift between the overviews via the SFCView Menu 21

Switch between the overviews via the Process Menu 23

Shift between the overviews in the Welcome Overview 24

Insert SFC View ActiveX in SFCView Overview 26

Insert SFC View ActiveX in Process Overview 28

VBA-Scripts  for the use of SFC View 30

VBA-Scripts for controlling the SPS 33

Operate Vijeo Look Project 35
17



Integration of SFC View in Vijeo Look
Nature of Tasks

Possibilities of 
the new project 
in Vijeo Look

After you have configured the new Vijeo Look  project as described in the following 
sections, the following possibilities are available to you in your new Vijeo Look 
project:
� Switching between the three overviews (Welcome, Process, SFCView) via 

operating buttons
� Display of the SFCView ActiveX-Controls in the three views:

� Overview (in the SFCView overview)
� Details (in the SFCView overview)
� Details Simple (in the Process overview)

� Send the following step chain commands to the PLC:
� Next step
� Set Initialize Flag
� Reset InitializeFlag
The sending of the step chain commands is done via operating buttons.

Representation 
of the three 
overviews

The individual overviews and switching possibilities between the individual 
overviews: 

Process SFCView

Chain Name   StepName   Parallel   Chain Status   Step Commen

Bitmap

Stepname with 32 chars

00s 000ms 00s 000ms

Stepname with 32 chars

00s 000ms 00s 000ms

Welcome Process SFCView NextStep SetIniFlag ResIniFlagWelcome SFCView

Welcome

Process SFCView
18    



Integration of SFC View in Vijeo Look
Configure new project and Prepare SFC View-ActiveX

Open the Unity 
Pro test project

Make sure that the Unity Pro test project (TESTSFCV.STU) is opened and saved in 
the PLC-Simulator (Starten and Use of the SFC View Demo Application, p. 12), 
before you begin with the configuring in Vijeo Look.
This ensures that SFC View can access the Unity Pro project data.

Configure 
new project 
in Vijeo Look

The following table describes the procedure for configuring a new project in Vijeo 
Look.

Changes in 
a Vijeo Look 
Project

Keep in mind that changes in a Vijeo Look Project only become fully effective once 
the project has been closed and then opened again.
 

Prepare SFC 
View-ActiveX 
for a project

The following table describes the procedure for preparing the SFC View-ActiveX for 
a project in Vijeo Look.

Step Action

1 Start Vijeo Look.

2 Click in the now opened dialog window Open a project on the command button 
New....

3 In the dialog window New Project enter a  Project name (e.g.. TestSFCView) 
and confirm it with OK.

Step Action

1 Open via Tools → Preferences → ActiveX Controls the dialog window 
ActiveX Controls Configuration.

2 Click in the left column on the ActiveX UnitySFCViewCtrl.SFCView and 
move it with the command button >> into the right column.

3 Make sure that the check in the checkbox is placed next to the SFC View-
ActiveX, so that the ActiveX is available later under the menu item Insert → 
Favorite ActiveX Controls.

4 Confirm with OK.
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Integration of SFC View in Vijeo Look
Create New Overviews

Overview, Image, 
Window

New Overview The following table describes the procedure to create new overviews.

Properties and 
names of the 
overviews

Properties and names of the individual overviews.

Note: The screen sides of a display, called Overviews in Vijeo Look, are also 
shown in other HMI applications as an image or window.

Step Action

1 In Vijeo Look open the project that you have configured in the previous section 
(e.g. TestSFCView).

2
Configure a new overview via the command button .

3 Configure a total of five new overviews.

4 The following table shows the properties and names of the individual overviews:

Name Position Size

Welcome X=0, Y=0 Width = 800, Height = 600

Process X=0, Y=0 Width = 800, Height = 550

SFCView X=0, Y=0 Width = 800, Height = 550

Process_Menu X=0, Y=550 Width = 800, Height = 50

SFCView_Menu X=0, Y=550 Width = 800, Height = 50

Note: Open the dialog field for changing the properties via right mouse button → 
Properties.... Saving is done via File → Save as....
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Integration of SFC View in Vijeo Look
Shift between the overviews via the SFCView Menu

General The shift can be done between the different overviews in Vijeo Look e.g. via 
Animate → Link or via VBA-Script .

Edit mode Make sure that you can only edit the views if you are in Mode → Design.

Switching to 
the Welcome 
Overview

Switch is made via Animate → Link.

Step Action

1 Open the overview SFCView_Menu.
Note: In order to make more space available on the overview, you can, under  
Properties → Style deselect all options, except for Border and Client Border.

2 Place, on the overview SFCView_Menu a text with the following properties:
� Text: Welcome
� Text size: 10, bold
� Position: X=0, Y=0
� Size: Width = 80, Height = 40
� Aspect: Button

3 Specify via Animate → Link → Open... , that by clicking on the operating button, 
the Welcome-Overview is opened.
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Integration of SFC View in Vijeo Look
Switching to 
the Process 
Overview

Switch is made via VBA script.

Switching to 
the SFCView 
Overview

Switch is made via VBA script.

Step Action

1 Place, on the overview SFCView_Menu a text with the following properties:
� Text: Process
� Text size: 10, bold
� Position: X=92, Y=0
� Size: Width = 80, Height = 40
� Aspect: Button

2 Click on the operating button and open via right mouse button → View Script 
the Visual Basic Editor.

3 Enter the following code:

Close the Visual Basic Editor.

4 By clicking on the operating button, the overviews Process and Process_Menu 
are now opened.

Private Sub Text2_Click()
Mimics.Open “Process”
Mimics.Open “Process_Menu”

End Sub

Step Action

1 Place, on the overview SFCView_Menu a text with the following properties:
� Text: SFCView
� Text size: 10, bold
� Position: X=184, Y=0
� Size: Width = 80, Height = 40
� Aspect: Button

2 Click on the operating button and open via right mouse button → View Script 
the Visual Basic Editor.

3 Enter the following code:

Close the Visual Basic Editor.

4 Save the overview SFCView_Menu.

5 By clicking on the operating button, the overviews SFCView and 
SFCView_Menu are now opened.

Private Sub Text3_Click()
Mimics.Open “SFCView”
Mimics.Open “SFCView_Menu”

End Sub
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Integration of SFC View in Vijeo Look
SFCView-Menu This is how the SFCView Menu  should now appear. 

Switch between the overviews via the Process Menu

Copy 
SFCView-Menu

Open the overview SFCView_Menu and save it as Process_Menu . 

Switching to 
the Process 
Overview

The switch to the  Process-view is not necessary in the process menu. Therefore, 
delete this button.
Save the overview Process_Menu.

Process Menu This is how the Process Menu  should now appear. 

Welcome Process SFCView

Note: Since you have already configured the overview Process_Menu you must 
confirm the question of whether you want to replace it.

Welcome SFCView
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Integration of SFC View in Vijeo Look
Shift between the overviews in the Welcome Overview

Switching to 
the Process 
Overview

Switch is made via VBA script.

Step Action

1 Open the overview Welcome.

2 Place, on the overview Welcome a text with the following properties:
� Text: Process
� Text size: 18, bold
� Position: X=184, Y=160
� Size: Width = 172, Height = 100
� Aspect: Button

3 Click on the operating button and open via right mouse button → View Script 
the Visual Basic Editor.

4 Enter the following code:

Save and close the Visual Basic Editor.

5 By clicking on the operating button, the overviews Process and Process_Menu 
are now opened.

Private Sub Text1_Click()
Mimics.Open “Process”
Mimics.Open “Process_Menu”

End Sub
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Integration of SFC View in Vijeo Look
Switching to 
the SFCView 
Overview

Switch is made via VBA script.

Welcome 
Overview

This is how the Welcome Overview should now appear. 

Step Action

1 Open the overview Welcome.

2 Place, on the overview Welcome a text with the following properties:
� Text: SFCView
� Text size: 18, bold
� Position: X=460, Y=160
� Size: Width = 172, Height = 100
� Aspect: Button

3 Click on the operating button and open via right mouse button → Display 
Script the Visual Basic Editor.

4 Enter the following code:

Save and close the Visual Basic Editor.

5 By clicking on the operating button, the overviews SFCView and 
SFCView_Menu are now opened.

Private Sub Text2_Click()
Mimics.Open “SFCView”
Mimics.Open “SFCView_Menu”

End Sub

Process SFCView
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Integration of SFC View in Vijeo Look
Insert SFC View ActiveX in SFCView Overview

General In this section you insert the SFC View-ActiveX into the Overview SFCView and 
specify the properties via the dialog window Object Properties.
So that SFC View Information is displayed for step chains, a few additional VBA-
Scripts must be programmed. This is explained in the following section.

Prepare SFC 
View-ActiveX

Before you can use SFC View, you must prepare ActiveX for each project (Configure 
new project and Prepare SFC View-ActiveX, p. 19).
 

Insert SFC View-
ActiveX

The following table describes the procedure for inserting ActiveX.

Properties of 
ActiveX

Properties of SFC View-ActiveX in the overview SFCView.

Step Action

1 Open the overview SFCView.

2 Insert, via Insert... → Favorite ActiveX Controls the ActiveX 
UnitySFCViewCtrl.SFCView.

3 Open the dialog window Object Properties and specify the properties as listed 
in the following table.

4 Save the overview SFCView.

Register Property Value

Aspect: Position X=5, Y=5

Size Width = 775, Height = 510

General Use OPC Project selected

ViewMode 0-sfcOverview

Note: For all properties not listed in the table, the preset values remain set.
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Integration of SFC View in Vijeo Look
SFCView-
Overview

This is how the SFCView-Overview should now appear. 

Chain Name   StepName   Parallel   Chain Status   Step Commen
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Integration of SFC View in Vijeo Look
Insert SFC View ActiveX in Process Overview

General In this section you insert the SFC View-ActiveX twice into the Overview Process 
and specify the properties via the dialog window Object Properties.
So that SFC View Information is displayed for step chains, a few additional VBA-
Scripts must be programmed. This is explained in the following section.

Prepare SFC 
View-ActiveX

Before you can use SFC View, you must prepare ActiveX for each project (Configure 
new project and Prepare SFC View-ActiveX, p. 19).
 

Insert SFC View-
ActiveX

The following table describes the procedure for inserting ActiveX.

Properties of the 
first ActiveX

Properties of the first SFC View-ActiveX in the overview Process.

Step Action

1 Open the overview Process.

2 Insert, via Insert... → Favorite ActiveX Controls the ActiveX 
UnitySFCViewCtrl.SFCView.

3 Repear Step 2.

4 Open the dialog window Object Properties and specify the properties as listed 
in the following table.

5 Save the overview Process.

Register Property Value

Aspect: Position X=80, Y=80

Size Width = 240, Height = 60

General Use OPC Project selected

ViewMode 2-sfcDetailsSimple

Chain Name SFC

Details Simple Show Chain Name
...
Show Initial Step Indicator

All properties
not selected

Note: For all properties not listed in the table, the preset values remain set.
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Integration of SFC View in Vijeo Look
Properties of the 
second ActiveX

Properties of the second SFC View-ActiveX in the overview Process.

Process-
Overview

This is how the Process Overview should now appear. 

Register Property Value

Aspect: Position X=440, Y=80

Size Width = 240, Height = 60

General Use OPC Project selected

ViewMode 2-sfcDetailsSimple

Chain Name SFC_ACT11

Details Simple Show Chain Name
...
Show Initial Step Indicator

All properties
not selected

Note: For all properties not listed in the table, the preset values remain set.

Note: The area shown in the previous graphic Bitmap could, for example, contain 
a display of the process to be observed.

Bitmap

Stepname with 32 chars
00s 000ms 00s 000ms

Stepname with 32 chars
00s 000ms 00s 000ms
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Integration of SFC View in Vijeo Look
VBA-Scripts  for the use of SFC View

General 
Information for 
the WorkSpace-
Script

The following is defined by this script:
� the Variable MainSFCView as an object for use in additional Scripts
� the Variable OPCAccessPath as a string for use in other scripts
� the OPCAccessPath via the Alias of the Unity Pro test project (TESTSFCV)
� the Start overview of the Vijeo Look Project (Welcome)

Creation of the 
WorkSpace-
Script

The following table describes the procedure when creating the script.

Switch to the 
SFCView 
Overview

The SFC View-ActiveX can be displayed in three different views (Overview, Details, 
Details Simple).
So that when clicking on the operating button SFCView  the SFC View-ActiveX is 
always in view: Overview is shown the script must be expanded for this operating 
button.
On the overviews Welcome, Process_Menu and SFCView_Menu one operating 
button of this type is used for each. Therefore, all three corresponding scripts must 
be expanded.

Step Action

1 Open the overview Welcome.

2 Click on an operating button and open via right mouse button → View Script 
the Visual Basic Editor.

3 Double-click in the project explorer in the directory Main (Work Space) on 
ThisProject. 

4 Enter the following code:

Save and close the Visual Basic Editor.

Private Sub fvProject_StartupComplete()

Mimics.Open “Welcome”
End Sub

Public MainSFCView As Object
Public SFCView_OPCAccessPath As String

--------------------------------------------------

SFCView_OPCAccessPath = “TESTSFCV“
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Expansion of the 
operating button 
script

In the following table, the procedure for the expansion of the operating script 
SFCView is described.

SFC View-
ActiveX for the 
SFCView-
overview

So that in the view SFCView the SFC View-ActiveX is displayed with the proper 
contents, a script must be created as follows for this view.

General 
information 
about the script 
for the process 
overview

The following is defined by this script:
� the OPCAccessPath via the Alias of the Unity Pro test project (TESTSFCV)
� the opening of the overview SFCView upon a double-click on an ActiveX
� the step chain that is then displayed in the overview (ChainName)
� the view in which the step chain is shown (ViewMode)

Step Action

1 Open the overview Welcome.

2 Click on the operating button SFCView and open via the right mouse button → 
View Script the Visual Basic Editor.

3 Expand the code as follows:

Close the Visual Basic Editor.

4 Also perform this expansion in the overviews Process_Menu and 
SFCView_Menu .

Private Sub Text2_Click()
Mimics.Open “SFCView”
Mimics.Open “SFCView_Menu”

End Sub
ThisProject.MainSFCView.ViewMode = 0

Step Action

1 Open the overview SFCView.

2 Click on the SFC View-ActiveX and open via the right mouse button → View 
Script , the Visual Basic Editor.

3 Delete the preset code.

4 Enter the following code:

Save and close the Visual Basic Editor.

Private Sub Mimic_Open()

SFCView1.OPCAccessPath = ThisProject.SFCView_OPCAccessPath
End Sub

Set ThisProject.MainSFCView = SFCView1
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Script for the 
process 
overview

The following table describes the procedure when creating the script.

Step Action

1 Open the overview Process.

2 Click on the left SFC View-ActiveX and open via the right mouse button → 
View Script , the Visual Basic Editor.

3 Delete the preset code.

4 Enter the following code:

Save and close the Visual Basic Editor.

Private Sub Mimic_Open()
SFCView1.OPCAccessPath=ThisProject.SFCView_OPCAccessPath

SFCView2.OPCAccessPath=ThisProject.SFCView_OPCAccessPath
End Sub
----------------------------------------------------------
Private Sub SFCView1_DetailsSimpleDblClick()

Mimics.Open "SFCView"
Mimics.Open "SFCView_Menu"
ThisProject.MainSFCView.ChainName = SFCView1.ChainName
ThisProject.MainSFCView.ViewMode = 1 'Details

End Sub
----------------------------------------------------------
Private Sub SFCView2_DetailsSimpleDblClick()

Mimics.Open "SFCView_Menu"
ThisProject.MainSFCView.ChainName = SFCView2.ChainName
ThisProject.MainSFCView.ViewMode = 1 'Details

End Sub

Mimics.Open "SFCView"
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VBA-Scripts for controlling the SPS

Create operating 
buttons

Place, on the overview SFCView_Menu the oeprating buttons (texts) with the 
following properties:

SFCView-Menu This is how the SFCView Menu  should now appear. 

Text Text size Position Size Aspect

NextStep  
10, bold
 

X=276, Y=0 Width = 80
Height=40

 
ButtonSetIniFlag X=368, Y=0

ResIniFlag X=460, Y=0

Welcome Process SFCView NextStep SetIniFlag ResIniFlag
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Creation of the 
Controlling-
Script

The following table describes the procedure when creating the script.

Step Action

1 Open the overview SFCView_Menu.

2 Click on the operating button Nextstep and open via the right mouse button → 
Display Script the Visual Basic Editor.

3 Expand the code as follows:

Save and close the Visual Basic Editor.

Private Sub Text2_Click()
Mimics.Open “Process”
Mimics.Open “Process_Menu”

End Sub

Private Sub Text3_Click()
Mimics.Open “SFCView”
Mimics.Open “SFCView_Menu”

End Sub

--------------------------------------------------------

--------------------------------------------------------
Private Sub Text4_Click()

--------------------------------------------------------
End Sub

ThisProject.MainSFCView.PLCGotoNextStep (True)

Private Sub Text5_Click()

--------------------------------------------------------

ThisProject.MainSFCView.PLCSetInitializeFlag (True)
End Sub

Private Sub Text6_Click()
ThisProject.MainSFCView.PLCSetInitializeFlag (False)

End Sub
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Operate Vijeo Look Project

Changes in a 
Vijeo Look 
Project

Keep in mind that changes in a Vijeo Look Project only become fully effective once 
the project has been closed and then opened again.
 

Open the Unity 
Pro test project

Make sure that the Unity Pro test project (TESTSFCV.STU) is opened and saved in 
the PLC-Simulator Starten and Use of the SFC View Demo Application, p. 12, 
before you open the Vijeo Look-Project.
This ensures that SFCView can access the Unity Pro Project data and you can 
observe projects in parallel in Unity Pro and Vijeo Look.

Switch between 
the overviews

From the Start overview of the Vijeo Look-Project (Welcome) you can switch via the 
operating heads SFCView and Processto the two other overviews. 

The switching between views can also be done via the respective menu bar in the 
lower part of the overviews.

Process SFCView

Chain Name   StepName   Parallel   Chain Status   Step Commen

Bitmap

Stepname with 32 chars

00s 000ms 00s 000ms

Stepname with 32 chars

00s 000ms 00s 000ms

Welcome Process SFCView NextStep SetIniFlag ResIniFlagWelcome SFCView

Welcome

Process SFCView
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Overview 
SFCView, 
View: Overview

If you change to the overview SFCView  the Unity Pro test project is shown as a 
standard in the view-overview.
View display: Overview. 

View components Overview

Number Components Description

1 Functional view After a project has been loaded directly or via the OFS, 
the functional view for the Unity Pro project is shown.
It is possible to navigate through the project via this 
functional view.

2 Functional project units If a functional unit was selected all the step chains for 
it are shown in the table on the right.
Note: All chains that are not assigned to a functional 
unit are shown in the main directory.

3 Information on the step 
chains

� Step chain name
� Name of the active step for each chain
� Number of parallel/alternative steps
� Chain state
� Step / chain comment

4A Selecting a step chain Click on the cell in the right table.
In the first column, an arrow is shown.

Overview

Chain Name Step Name Parallel Chain Sta- Step Comment
SFC_para S_3_5 1 Running Step sets ACT5.ACT5 is mapped to I/O but not read by any logi

SFC_seq S_4_1 1 Running Step sets ACT13.ACT13 is mapped to I/O but not read by any lo

1 2 3

Station

SFCDiag
PLCDiag

4 5
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4B Selecting more than 
one step chain

Click in a line in the right hand table and confirm by 
pressing the spacebar.
Instead of an arrow in the first column, a cross is 
shown.
Using this method you can select more than one step 
chain and for all chains at once, apply e.g. the 
PLCSetInitializeFlag method.
Note:
If more than one step chain is marked by a cross, the 
method to be implemented acts on them. A step chain 
that is marked with only one arrow is considered in this 
case to be not selected.

5 Switching to another 
view

You can switch to a different view (Details) by double-
clicking on a step chain.

Note: By double-clicking on a step chain, this step chain is in view: Show details. 
Via the operating button SFCView you will get back to the view: Overview.

Number Components Description
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Overview 
SFCView, 
View: Details

View display: details. 

View components Details

Number Components Description

1 Chain name Name of the selected chain

2 Status flags Shows the state of step chain. The state is represented 
using a color outline.

3 Number of active steps 
and navigation

Dislpay for number of active steps.
The arrow keys can be used to navigate between the 
active parallel steps.

4 Parallel/alternative 
branches

Display of parallel (double line) or. Alternative 
branches (single line)

Unity SFCView Demo - C:\Programme\Schneider Electric\Unity SFCView\testsfcv.stu

Section Disabled
Chain Name

Initialize Flag Set Time Check Disabled Transitions Disabled Actions Disabled

1(2)

Stepname with 32 charts maximum
Three lines of comment text

This is for a short error message
00s 000ms

Stepname with 32 charts maximum
Three lines of comment text

Transition variable
Three lines of comment text

Qf Time Name Comment

Qf Time Name Comment

Cause Error State Pin State

00s 000ms

Type

Type

12 35 8 710 4 6 9
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5 Information on the 
active steps

� Active step name
� Comment (three lines)
� Short Error message
� Delay Time
� Current dwell time
The outline around this info field can have a different 
color depending on the state of the step.
On the right hand side the actions for the step are 
displayed.

6 Information on the 
actions for the active 
step

� Identifier
� Time
� Name of variables or the section
� (variable or section type)
� Comment
The background color for the variables can have a 
different color depending on the state of the variable.

7 Information on 
transitions

� Name of transition variables
� Comment (three lines)
The rectangle representing the transition can have a 
different color depending on the state of the transition.

8 Information on the 
following step

� Next step name
� Comment (three lines)
� Short Error message:
� Delay Time
� Current dwell time
On the right hand side the actions for the step are 
displayed.

9 Information on the 
actions for the next 
step

� Identifier
� Time
� Name of variables or the section
� (Variable or Section type)
� Comment

10 Diagnostic information Display of error messages for the transition. Which 
diagnostic information is shown can be set individually 
by the user.

Number Components Description
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Overview 
Process

If you change to the overview Process the chains of the Unity Pro test project, which 
you have defined via the properties of the SFCView, are displayed in the 
view:Details Simple Insert SFC View ActiveX in Process Overview, p. 28.
By double-clicking on one of the two chains, it is then shown in the overview 
SFCView in the view: Details.

Control PLC Via the operating buttons NextStep, SetIniFlag and ResIniFlag you can control the 
PLC or in this case the PLC simulator.
With NextStep you switch the step chain a step further independently of whether the 
transition has been met.
With SetIniFlag you set the Initialize-Flag for the selected chain.
With ResIniFlag you reset the Initialize-Flag for the selected chain.
Activate the individual operating buttons and observe what changes in the display of 
the SFCView-ActiveX.
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